FAQ  •  Inscription  •  Connexion

  • Publicité

fabrication du PT

<<

Digitaleos

Middle user
Middle user

Messages: 18

Inscrit le: 21 Avr 2016, 19:35

Message 24 Août 2016, 21:23

Re: fabrication du PT

Bonsoir Thierry,
Prends ton temps, la semaine prochaine je n'aurai pas de temps à y consacrer.
@+
Martial

Publicité

<<

ThierryD

Avatar de l’utilisateur

Administrateur
Administrateur

Messages: 1519

Inscrit le: 01 Nov 2010, 22:24

Message 31 Août 2016, 21:15

Re: fabrication du PT

Bonjour,
j'ai tout repris à zéro.
J'ai pris ta librairie, j'ai pris le même exemple que toi et j'ai modifié le code comme toi avec :
UTFT myGLCD(SSD1289,38,39,40,41);
int ledPin=12;
void setup()
{
randomSeed(analogRead(0));
pinMode(ledPin,OUTPUT);
digitalWrite(ledPin,LOW);
// Setup the LCD
myGLCD.InitLCD();
myGLCD.setFont(SmallFont);
}

Sur mon LCD j'obtiens un écran noir rétro éclairé ce qui donne un gris / blanc mais aucun affichage.
Donc pour moi, ta librairie ne fonctionne pas avec mon LCD.
Donc j'ai quand même repris à zéro les modifications de cette librairie pour l'adapter pour le programme du Photographer Tools.

Je te joins 2 ZIP :
- Le premier c'est le code de démo que tu as testé avec succès et qui fonctionne pour toi
- Le deuxième c'est ta librairie adaptée pour le code du PH Tools.

Peux tu tester les deux programmes et vérifier que cela fonctionne.
Si cela ne fonctionne pas déjà pour le premier programme alors j'aurais du mal à comprendre puisque c'est exactement le même code que celui que tu as testé.

Cordialement,
ThierryD.
Pièces jointes
Donwload Program Into ARDUINO DUE 2.zip
(435.8 Kio) Téléchargé 120 fois
Donwload Program Into ARDUINO DUE 1.zip
(344.79 Kio) Téléchargé 126 fois
NIKON D7100 *** NIKON 17-55 mm AF-S DX f/2.8G G IF ED *** SIGMA 70-200 mm F2,8 APO DG OS EX HSM Nikon D *** SIGMA 120-400mm F4,5-5,6 DG APO OS HSM Nikon D *** SIGMA 105mm F2.8 EX DG MACRO OS HSM *** SIGMA 8-16 mm F4.5-5.6 DC HSM *** Flash SB600
<<

Digitaleos

Middle user
Middle user

Messages: 18

Inscrit le: 21 Avr 2016, 19:35

Message 01 Sep 2016, 00:14

Re: fabrication du PT

Bonsoir Thierry,

ça maaaaaaaaaaaaaaaaarche ! :D
t'es génial.
A moi de maitriser la bête.

Merci, merci

Cordialement

Martial
<<

Digitaleos

Middle user
Middle user

Messages: 18

Inscrit le: 21 Avr 2016, 19:35

Message 31 Mars 2020, 00:15

Re: fabrication du PT

Bonjour Thierry,
Après avoir fabriqué un stand pour faire du "water drop" je reviens vers toi pour résoudre des problèmes de déclenchement avec un bouton poussoir sur l'entrée auxiliaire AUX1.
J'ai suivi un de tes schémas, à savoir résistance de 100k entre le + 5V et l'entrée et le bouton poussoir NO entre l'entrée et la masse. J'utilise une sortie pour déclencher le relais qui va générer la goutte d'eau et une sortie retardée pour déclencher un flash. Les 2 sorties sont pilotées par l'entrée AUX1 avec bouton poussoir.
Programmation OUT1 et OUT2 :
-- Lower/Upper = FALSE - mesure = true -> les sorties sont toujours actives
-- Lower/Upper = TRUE - mesure = false -> les sorties sont toujours inactives
J'ai fait des mesures de tension sur la prise AUX1 + B.P. : j'ai trouvé le +5V à +3.3V ; tension entrée/masse : 1.34V; tension aux bornes de la résistance 100k : 1.95V (normal)

J'ai remplacé la résistance par une 10k => tension entrée/masse : 1.77V
-- Lower/Upper = FALSE - mesure = false - quand appui sur le B.P. la mesure passe à true et les sorties sont enclenchées = fonctionnement attendu :D
-- Lower/Upper = TRUE - mesure = true - les sorties sont toujours enclenchées et la mesure passe à false quand appui sur le B.P.

1ère question : pourquoi le +5V est à +3.3V ?
2ème question : la résistance de 10k est-elle optimale sur l'entrée auxiliaire ?

Autre sujet : j'ai essayé de communiquer en bluetooth entre PT et mon smartphone (samsung S7). J'ai utilisé une application Bluetooth terminal. L'application trouve HC06 et s'y connecte sans problème et sans mot de passe mais lorsque j'envoie les codes que tu fournis il ne se passe rien. Qu'est-ce que je ne comprends pas ?

J'ai tout de même réussi à faire quelques photos dont il ne faut pas rechercher le côté artistique, c'était juste un essai de fonctionnement.
Pièces jointes
IMG_0450r.JPG
IMG_0450r.JPG (265.26 Kio) Consulté 136 fois
<<

Digitaleos

Middle user
Middle user

Messages: 18

Inscrit le: 21 Avr 2016, 19:35

Message 04 Avr 2020, 11:26

Re: fabrication du PT

Bonjour Thierry,
Je viens de tester le remote module en wifi. Il ne se connecte pas du premier coup au PT, il faut que j'éteigne/rallume le PT plusieurs fois pour établir la connexion. Le remote module se trouve à quelques dizaines de centimètres du PT.
Les 2 boitiers sont alimentés en 12V à l'aide de petits transfos secteur type chargeurs.
Y a t-il un correctif à apporter ?
mes modules wifi sont ceux en pièce jointe.
Merci de ton aide
Pièces jointes
20200404_111510_r.jpg
20200404_111510_r.jpg (81.23 Kio) Consulté 136 fois
<<

Jfringeisen

Middle user
Middle user

Messages: 19

Inscrit le: 31 Juil 2019, 17:18

Message 10 Avr 2020, 18:19

Re: fabrication du PT

Bonjour, j'ai eu exactement le même problème suite a la casse du LCD, la fabrication de l'ancien LCD est arrêtée. Si on a la chance d'en trouver ce sont des fins de stock... Le problème vient du contrôleur ILI9341 dont il sont équipé maintenant et le programme actuel de Thierry ne prend pas en charge la bibliothèque de ce contrôleur.
<<

Digitaleos

Middle user
Middle user

Messages: 18

Inscrit le: 21 Avr 2016, 19:35

Message 11 Avr 2020, 19:06

Re: fabrication du PT

Bonjour,
Merci pour la réponse. Lorsque j'ai fabriqué le PT (il y a 4 ans) j'ai eu des problèmes d'affichage à cause du driver ILI9341 et j'ai fini par trouver un afficheur à SSD1289 comme le précise Thierry dans la liste des composants. Malgré tout il a dû recompiler le soft pour l'adapter à un autre problème d'affichage que j'avais malgré le SSD1289. Y aurait-il encore un bug autour de cela ? La connexion finit par se faire mais c'est au prix de plusieurs démarrages en alternant le PT et le remote module sans trouver la bonne démarche (si tant est qu'il y en ait une).
J'attends des nouvelles de Thierry si il a déjà rencontré ce problème.
<<

Jfringeisen

Middle user
Middle user

Messages: 19

Inscrit le: 31 Juil 2019, 17:18

Message 12 Avr 2020, 13:38

Re: fabrication du PT

J'avais un LCD qui "fonctionnait" mais avec un décalage entre les fenêtres de paramétrage et la position d’accès sur la partie droit du LCD
Précédent

Retour vers QUESTIONS AND ANSWERS (Questions et réponses)

Qui est en ligne ?

Utilisateur(s) parcourant actuellement ce forum : Aucun utilisateur inscrit et 1 invité

  • Publicité
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software.
Traduction réalisée par Maël Soucaze © 2010 phpBB.fr